Subject: Re: No buffer memory
To: Bill Chiarchiaro <>
From: Gary Duzan <>
List: current-users
Date: 01/13/2004 14:56:18
In Message <> ,
   Bill Chiarchiaro <> wrote:

=>There have been different descriptions of what I've believed to be the
=>same problem.  Some people say that umass devices won't attach properly
=>unless they're physically connected at boot time.  Others say that it
=>doesn't make any difference whether they're connected at boot time,
=>but after some amount of time (hours to weeks) since booting, umass
=>devices no longer attach properly.  I've observed the latter symptoms
=>on my system, and I've regarded them as a superset of the former
=>Gary, from your comment about a buffer leak, I infer that you had been
=>seeing the former symptoms.  Is that correct?

   I never bothered with boot-time testing. My umass device is a
Memorex Thumbdrive (sp?) flash device, and there was no way I was
going to reboot the machine just to have it recognised.  I went
ahead and tried running with KMEMSTATS enabled in the kernel, but
then realized that it was the DMA buffers that were most likely
the problem, and they all get lumped together in the "vmstat -m"
stats, so that wasn't going to help. Ah, well...

   My "buffer leak" comment was in response to your observation
that it worked for a while and then quit. My guess is that you had
enough kmem to get umass buffers a few times, but they weren't
deallocated at disconnect, and once it ran out you were stuck.

					Gary Duzan