Subject: Re: Sony DSC-T1 and umass
To: Eric Haszlakiewicz <>
From: Bill Chiarchiaro <>
List: current-users
Date: 01/13/2004 10:53:49
Eric Haszlakiewicz wrote:

> 	Try "scsictl /dev/scsibusX detach all all" followed by 
> "scsictl /dev/scsibusX scan all all".  That might get the other drives
> to show up.

I had tried the "scan all all" yesterday, but it didn't help.  Today,
I tried "detach all all" followed by "scan all all", and the system
still configured only /dev/sd0 (or /dev/sd0e).  That drive corresponds
to whichever of the two cards was inserted into the 8-in-1 reader
first, prior to doing the detach and scan.

> 	Does sd0 automatically show up when you plug in a memory card?  The
> model of reader that I have doesn't notice, so I always have to do
> the manual detach/scan.

With my SanDisk 8-in-1 reader and with my SanDisk CF-only reader, I
don't have to do anything more than plug in the reader, insert a card,
and then 'mount_msdos /dev/sd0e /mnt' (assuming the umass memory
allocation bug doesn't occur).  A typical set of messages seen upon
plugging in the reader is:

Dec 28 11:18:54 roseneck /netbsd: umass0 at uhub0 port 1 configuration 1 interface 0
Dec 28 11:18:54 roseneck /netbsd: 
Dec 28 11:18:54 roseneck /netbsd: umass0: SanDisk ImageMate 8 in 1, rev 2.00/1.28, addr 2
Dec 28 11:18:54 roseneck /netbsd: umass0: using SCSI over Bulk-Only
Dec 28 11:18:54 roseneck /netbsd: scsibus0 at umass0: 2 targets, 4 luns per target
Dec 28 11:18:54 roseneck /netbsd: scsibus0: waiting 2 seconds for devices to settle...
Dec 28 11:18:56 roseneck /netbsd: sd0 at scsibus0 target 1 lun 0: <Generic, STORAGE DEVICE, 0128> SCSI0 0/direct removable
Dec 28 11:18:56 roseneck /netbsd: sd0: drive offline

No messages result from inserting the card, nor from removing it after
unmounting it.  Mounting it does generate messages about fictitious
geometry and lack of a disk label.  When unplugging the reader:

Dec 28 12:17:48 roseneck /netbsd: umass0: at uhub0 port 1 (addr 2) disconnected
Dec 28 12:17:48 roseneck /netbsd: sd0 detached
Dec 28 12:17:48 roseneck /netbsd: scsibus0 detached
Dec 28 12:17:48 roseneck /netbsd: umass0 detached

I don't have a pressing need for copying directly from one type of
flash card to another (as SanDisk claims can be done with the 8-in-1,
at least under Windows), but that "4 luns per target" message is
tantilizing and it would be fun to see this work.

Bill Chiarchiaro