Subject: bios boot 3.1 failure
To: None <>
From: Nino Dehne <>
List: current-users
Date: 12/07/2003 04:17:45

to describe the problem, here is what I did from the start:

dd if=/dev/zero of=/dev/rwd0d bs=65536
newfs distribution from another disk onto wd0[aefg]
    using cvsup'd source with *default date=2003.
cp /mnt/usr/mdec/boot /mnt/
    /mnt is wd0a
installboot -v -o console=com0 /dev/rwd0a /mnt/usr/mdec/bootxx_ffsv1
    alternatively, console=pc was tried as well as omitting it

When I boot that disk on an Intel D865PERLK board it works just fine. 
However, the disk is destined for another system using an AOpen AX37 
Plus board. After receiving the following on the serial console there 
the loader just hangs:

 >> NetBSD/i386 BIOS Boot, Revision 3.1
 >> (root@[...], Sat Dec  6 04:13:08 CET 2003)
 >> Memory: 640/261120 k

So I went plugging in a vga card and retried. Symptom now being the 
video card producing out-of-range frequencies for the monitor (distorted 
video, sometimes the monitor tries switching modes like mad). I tried 
reinstalling the loader on the same system it should boot to no avail.

I tried using -o resetvideo. This helped with the video garbage and got 
me a nice blinking corsor top left. The loader hung anyway.

Does this ring a bell for anyone? 1.6.1's revision 2.13 loader works 
just fine.


Of course it runs NetBSD.

42A5E773 - 41DE 4A4C DB34 33F7 2044  8FE0 91AA C584 42A5 E773