Subject: building current 20031123
To: None <>
From: Axel Scheepers <>
List: current-users
Date: 11/24/2003 11:56:20
Hi All,

I've been trying to build current for about the past week now, but the 
release has never build correctly.
Some errors, although not fatal according to, occur during the 
userland build. A small snippet of these;
postfix check:
/home/NetBSD/builds/i386/distribution//etc/postfix/postfix-script doe
s not exist
not exist
/home/NetBSD/builds/i386/distribution//etc/postfix/postfix-files does
  not exist
obsolete check:
sort: /home/NetBSD/builds/i386/distribution//var/db/obsolete/*: No such file
or directory
sendmail check:
         sendmail_suidroot variable not set (assuming ``no'')
.: Can't open /home/NetBSD/builds/i386/distribution//etc/rc.subr
: permission denied
stat: unknown option -- q
usage: stat [-FlLnrsx] [-f format] [-t timefmt] [file ...]
binary has wrong owner/mode
         /home/NetBSD/builds/i386/distribution//etc/mail/ is 
stat: unknown option -- q
usage: stat [-FlLnrsx] [-f format] [-t timefmt] [file ...]
         Client queue / has wrong owner/mode

But the build ends succesfully;
===> Summary of results:
 command: ./ -m i386 -D 
tribution -O /home/NetBSD/builds/i386/obj -T /home/NetBSD/builds/tools 
-R /ho
me/NetBSD/builds/i386/release -u build
 started: Sun Nov 23 21:00:15 CET 2003
          MACHINE:          i386
          MACHINE_ARCH:     i386
          TOOLDIR path:     /home/NetBSD/builds/tools
          DESTDIR path:     /home/NetBSD/builds/i386/distribution
          RELEASEDIR path:  /home/NetBSD/builds/i386/release
          makewrapper:      /home/NetBSD/builds/tools/bin/nbmake-i386
          Updated /home/NetBSD/builds/tools/bin/nbmake-i386
          Successful make build
 started: Sun Nov 23 21:00:15 CET 2003
 ended:   Mon Nov 24 00:39:19 CET 2003
===> .

In my /home/NetBSD/builds/i386/distribution I can see a somewhat 
complete installation now, so I tried building a release from that, but 
that fails according to missing files in the man/doc section. Again a 
snippet of my release build logs;
============  extra files  ===============
Files in DESTDIR but missing from flist.
File is obsolete or flist is out of date ?
========  end of missing files  ==========

*** Failed target:  checkflist
*** Failed command: DESTDIR=/home/NetBSD/builds/i386/distribution 
6 MACHINE_ARCH=i386 CKSUM=/home/NetBSD/builds/tools/bin/nbcksum 
tBSD/builds/tools/bin/nbmake MTREE=/home/NetBSD/builds/tools/bin/nbmtree 
bpax sh /home/NetBSD/src/distrib/sets/checkflist
*** Error code 1
ERROR: Failed to make release

I browsed the archives a bit for more information, and some people 
mention breaking current when building the docs/man pages, although I 
couldn't find anything relevant to fix it. (except rebuilding from a 
fresh cvstree, which I did for the past week)

Anyway, I'm left with some small questions;

Do I need to update some base-system tools before trying to build a 
release? BUILDING mentiones will make all the neccesary tools 
and use them instead of the base system ones, which according to my logs 
it does. (but it might need an updated stat for instance, I couldn't 
find a note in UPDATING about it)

Am I building current 'the right way'?
Now I'm running a script which tries to autobuild current like this;
- update source to today's current with cvs
- setenv BHOME /home/NetBSD/builds/i386
- ./ -m i386 -D $BHOME/distribution -O $BHOME/obj -T 
$BHOME/tools -R $BHOME/release tools
- ./ -m i386 -D $BHOME/distribution -O $BHOME/obj -T 
$BHOME/tools -R $BHOME/release kernel=GENERIC
- ./ -m i386 -D $BHOME/distribution -O $BHOME/obj -T 
$BHOME/tools -R $BHOME/release -u build
- ./ -m i386 -D $BHOME/distribution -O $BHOME/obj -T 
$BHOME/tools -R $BHOME/release -u release

I'd like to keep all in /home/NetBSD, since that's where I have the 
space needed to build it. I was hoping to build a full release for all 
my architectures and install/update some boxes from that instead of 
doing a ./ install=/.
I also noticed several posts about problems when using -u. This switch 
should preserve already build object files if I understand correctly, 
I'd like to keep that if possible; the box has to build 4 releases so 
anytime I can spare is welcome. I've tried without -u several times, but 
that didn't make a difference.
(Note that I didn't build any other relase then i386 yet, but it 
shouldn't do any harm because it uses different directories for 
everything except the tools)

The build host is an i386 1.6.1 box.

For the full logs of everything see

Thanks for any help,
Kind regards,

Axel Scheepers