Subject: Re: Disklabel problems.
To: Adam K Kirchhoff <>
From: David Laight <>
List: current-users
Date: 11/11/2003 13:48:40
On Tue, Nov 11, 2003 at 07:06:51AM -0500, Adam K Kirchhoff wrote:
> Last night I installed a snapshot of NetBSD (1.6U) onto my system at home.

An interesting choice - somewhat old now....

> So far everything works fine, except I'm unable to see the msdos partition
> that I have grub installed on.
> I use this machine to try out and test lots of different OSes, and I use
> grub to boot between them all.  Here's a rough idea of the layout of the
> filesystems.
> wd0 	1) msdos FS (grub)
> 	2) ext3
> 	3) extended (with 4 or 5 ext3 partitions)
> wd1	1) NTFS
> 	2) FreeBSD
> 	3) ext3
> sd0	1) NetBSD
> sd1	1) BeOS
> If I run 'disklabel' on wd1, sd0, or sd1, I can view the layout of the
> filesystem.  If I run disklabel on wd0, though, nothing happens.  No
> errors, no output, no prompt.  The command just runs and runs and runs....
> And runs.  Nothing shows up in dmesg.  My hard disk doesn't make sickly
> noises.

It is interruptable?  Or is it looping in the kernel?

> This is a problem since it means I can't mount the msdos partition to edit
> my grub entries.
> Can anyone offer any suggestions on how to fix this or how to futher
> diagnose the problem?

What does NetBSDs fdisk say about wd0?
Depending on the version (I've forgotten when 1.6U was) one or more -v
will give more info.

If you run current (probably later than 1.6U) the kernel ought to have
code to generate a label from the extended partition list.


David Laight: