Subject: Disklabel problems.
To: current-users <>
From: Adam K Kirchhoff <>
List: current-users
Date: 11/11/2003 07:06:51
Last night I installed a snapshot of NetBSD (1.6U) onto my system at home.
So far everything works fine, except I'm unable to see the msdos partition
that I have grub installed on.

I use this machine to try out and test lots of different OSes, and I use
grub to boot between them all.  Here's a rough idea of the layout of the

wd0 	1) msdos FS (grub)
	2) ext3
	3) extended (with 4 or 5 ext3 partitions)

wd1	1) NTFS
	2) FreeBSD
	3) ext3

sd0	1) NetBSD

sd1	1) BeOS

If I run 'disklabel' on wd1, sd0, or sd1, I can view the layout of the
filesystem.  If I run disklabel on wd0, though, nothing happens.  No
errors, no output, no prompt.  The command just runs and runs and runs....
And runs.  Nothing shows up in dmesg.  My hard disk doesn't make sickly

This is a problem since it means I can't mount the msdos partition to edit
my grub entries.

Can anyone offer any suggestions on how to fix this or how to futher
diagnose the problem?