Subject: Re: Anyone got ATAPI tape drives to work?
To: Bert Kiers <>
From: Stefan Schumacher <>
List: current-users
Date: 11/10/2003 21:01:27
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

* Bert Kiers ( wrote:
> On Mon, Nov 10, 2003 at 04:58:58PM +0100, Bert Kiers wrote:
> > On Mon, Nov 10, 2003 at 11:11:25AM +0000, Stephen Borrill wrote:
> > I have
> >=20
> > st0 at atapibus0 drive 1: <HP      COLORADO 5GB, US04090639, 2.01000> t=
ype 1 sequential removable
> > st0: drive empty
> > st0: 32-bit data port
> > st0: drive supports PIO mode 4, DMA mode 2
> > pciide0: secondary channel interrupting at irq 15
> > st0(pciide0:1:1): using PIO mode 4, DMA mode 2 (using DMA data transfer=
> >=20
> > on
> >=20
> > NetBSD cuddle 1.6.2_RC1 NetBSD 1.6.2_RC1 (CUDDLE) #5: Sun Nov  9 17:37:=
48 CET 2003     kiers@cuddle:/usr/src/sys/arch/i386/compile/CUDDLE i386
> >=20
> > and it just works.
> No, it does not. It behaves exactly as you describe in the two mail
> references. (Was working from memory in the previous mail, sorry).

I also use a HP Colorado 5GB since ATAPI was supported in IIRC 1.5-current
and I don't have any problems with dump -0au /dev/wd0e although I sometimes
also see those strange "reverse density" errors.=20

But I use ist for over 1 year now, and I was able to restore tapes w/o
problems for ~5 times.=20

The only thing that I really dislike is that I can't use mt to fsf or bsf
the tape (but this might be PEBKAC).

She covers the earth with a breathtaking cloak
The sun awakes and melts it away
The world now opens its eyes and sees
The dawning of a new day    -- Within Temptation - Ice Queen

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.2.3 (NetBSD)