Subject: Re: problems with 1.6ZE
To: Current Users <>
From: Jukka Marin <>
List: current-users
Date: 10/31/2003 20:12:19
On Fri, Oct 31, 2003 at 10:07:10AM -0600, David Young wrote:
> On Fri, Oct 31, 2003 at 04:32:51PM +0200, Jukka Marin wrote:
> > I just tried a 1.6ZE kernel on my TP A31p.  I have three problems:
> > 
> > dd'ing a disk image onto a CF card does not work reliably.  I copy the
> > image like this:
> > 
> > # dd if=foo.img of=/dev/rwd1d bs=1m progress=1
> Does the geometry of the disk image agree with the geometry of the CF
> card? If not, I would not expect for dd'ing the image to produce a card
> that passes fsck.
> I notice that the geometries of your example cards disagree:

True, but it seems that writing to CF is unreliable.  Every dd produces
a different copy - reading the CF card using dd works reliably.  The
error in write seems to occur at offset (disk block boundary + 1) bytes
(like 0x06c00001 or 0x00150001).  After this point, the rest of the CF
contents are wrong (as if part of the data written was skipped or

On Fri, Oct 31, 2003 at 08:16:24AM -0800, Andreas Gustafsson wrote:
> I see this same error if I run with a -current kernel but an older
> version of fsck.  Perhaps that's the cause in your case, too?

Well, it seems that writing to the CF card is failing, so the CF contents
really are broken.. don't know why.  The older CF card works reliably.