Subject: Re: HEADS UP! Default value of ip6_v6only changed
To: der Mouse <mouse@Rodents.Montreal.QC.CA>
From: George Michaelson <>
List: current-users
Date: 10/28/2003 22:00:52
[sorry. bad fingers on a laptop -ggm]

On Tue, 28 Oct 2003 06:38:50 -0500 (EST) der Mouse
<mouse@Rodents.Montreal.QC.CA> wrote:

> > And why is it, that I cannot reliably browse into V6 nodes like the
> > kame site to see the dancing turtle from this browser?
> Again, I can only conjecture.  This time my guess is that v6
> connectivity between you and the site in question is not in good shape;
> I know that in my own experience, v6 connectivity is often much worse
> than v4 connectivity, even when the endpoint hosts are the same.
> Comparing traceroute output with traceroute6 output may be useful.

No, I know about the V6 overlay problems, I work for the agency which hands v6
addresses out in Asia, and I have a v6 overlay net. I pre-tested my connectivity
with traceroute6 before attempting the connect, I could telnet to the 6 address
and get the HTML. 

Its specifically that either because of /emul wierdness, or code lazyness in
mozilla, or conflicts in NetBSD code about what v6only means, effectively
prevented the browser from making the fetch.

Since web is like the reason significant numbers of people are online, this
is badness for a v6 deployment story, and a 'unix desktops work in the real
world' story. Of course neither you nor I will care much in this point of the
post NCP world, but at some stage, documentation has to match reality. I think
the MESSAGE should maybe read:

	V6 support in Mozilla is broken. Wierdness can happen if your URL
	resolves to a AAAA and a V4 A record, or even to AAAA alone. YYMV.


George Michaelson       |  APNIC
Email:    |  PO Box 2131 Milton QLD 4064
Phone: +61 7 3367 0490  |  Australia
  Fax: +61 7 3367 0482  |