Subject: ESS1879 sound issues
To: None <>
From: None <>
List: current-users
Date: 10/13/2003 15:51:11
	This relates to pr#23145 in port-i386. The ESS 1879 audio chipset
is not configured by the NetBSD kernel. I have tried both 1.6.1_STABLE and
also -current as of 10/10/2003. I am using a Hewlett Packard Omnibook
Sojourn which has this chipset built in as a pnpisa device. The Japanese
Mitsubishi Pedion is identical to this laptop. The manufacturer is, in
fact, Mitsubishi.
	The audio interface has a plug 'n play ID string of "ESS1879". The
laptop is rather old (233MMX Pentium). The only freeware drivers I know of
are those for FreeBSD and the Linux ALSA drivers. The chipset is
full-duplex and should work with a standard 18XX series driver.
	I tried editing the isapnpdevs file in /usr/src/sys/dev/isapnp and
also the strings in ess_pnpbios.c located in
/usr/src/sys/arch/i386/pnpbios but it would appear that more work is
needed to get it working. Those files, did not, however seem to have any
knowledge of the ESS1879 (only the ESS1878 in -current).
	Is there some other files I should be looking at editing? I'm
pretty sure that some work has already been done to make this chipset work
because both ess.c and ess.h in /usr/src/sys/dev/isa have references to
the 1879 chipset.

Any help is appreciated.