Subject: Re: SDLT 320 Tape Drive on -current (SOLVED!!!)
To: None <>
From: Duncan McEwan <>
List: current-users
Date: 10/01/2003 13:19:03
A few weeks ago I wrote:

> ...
> So at this stage I'm still not sure whether we are looking at a (second)
> faulty tape drive (or scsi controller) or whether there are perhaps problems
> with the NetBSD ahc or st drivers.  Any advice would be gratefully accepted!
> ...

To which Manuel Bouyer replied:

> This really looks like as a hardware problem on the drive side again
> I can't see how a faulty driver could cause such coherent SCSI sense messages.

OK, I think we have finally got this problem sorted out, so for completeness of
the list archives, and to possibly help anyone else who might have a similar
problem, here's what we found out.

First off, we had an old AHA 3940 controller card lying around, and so I decided
to try the tape drive with that card, both in a win2k box and also NetBSD.
We didn't get any errors on either.

I reported this to Dell and finally got someone who was able to tell us about
a firmware upgrade for the aic7899 based scsi adaptor.  We upgraded the firmware
according to the instructions (basically involved creating a boot floppy from
a downloaded windows executable and booting the machine off that floppy) and
since that upgrade (now over a week ago) we haven't noticed any problems!

The firmware that our card did have was version 2.57.252 which was copyrighted
in 2000 (according to the bios messages printed at boot time).  The firmware
upgrade took it up to version 3.10 (which the download page dated as 5/27/2003).

You can find the download page on the Dell support web site by selecting
"Downloads for your Dell", then filling in the form with your server type, ALL
operating systems, ALL download categories and then under the "SCSI non-RAID
Controllers" section you should see "Adaptec 39160 SCSI Controller - Firmware".

The download page listed a number of bugs that were fixed, amongst which was
"7899 BIOS/BDK Violates SCSI Spec for Selection Timeout", which could perhaps be
what was biting us.

Finally, thanks to Manuel for his responses to my postings  It might have turned
out not be a tape drive fault, but he did convince me that it wasn't a NetBSD
driver error and so it was worth more experimentation on Windows and worth
talking to Dell some more...