Subject: Re: Now I've really done it: I have no more mbr
To: Geoff Wing <>
From: Hisashi T Fujinaka <>
List: current-users
Date: 08/18/2003 22:26:50
On Tue, 19 Aug 2003, Geoff Wing wrote:

> Hisashi T Fujinaka <> typed:
> : OK, so is there some way of mounting the entire disk and searching for
> : /var/backup to regenerate my mbr or am I totally hosed this time?
> The MBR can be regenerated but you have not really given much information
> on what your setup is nor what actions you've taken which makes it hard
> to suggest what steps you need to take to fix it.
> It seems to be NetBSD on disk 0, WinXP on disk 1.  Is this right?
> And you were trying to put a multidisk loader on but caused a problem
> with your NetBSD MBR?

This is very correct. I added grub, and then expected a nice linuxy grub
experience, but could not get netbsd to completely boot. It would
print out all the hardware intitialization messages, but then get to a
point where it said "root:" and hang. So I tried to delete grub and get
back to the netbsd bootloader. I tried installboot, fdisk -B, fdisk -i,
etc, reading the man pages and doing the things that seemed, well,
likely to fix things. Somewhere in all of that, I destroyed the mbr. Now
it won't boot at all, and booting to windows showed me that I have no
partition table.

I used to have two netbsd partitions and one dos partition on disk 0.
Disk 1 is WinXP. When I installed XP, I had disk1 disconnected and disk1
was the primary. I don't think that had much effect on this current

So now I made WinXP the primary disk, and the destroyed disk the
secondary, and I'm using a sector editor to root through the disk. This
could take a while.

Hisashi T Fujinaka -
BSEE(6/86) + BSChem(3/95) + BAEnglish(8/95) + MSCS(8/03) + $2.50 = latte