Subject: Re: libiconv not working
To: Hisashi T Fujinaka <>
From: Steven M. Bellovin <>
List: current-users
Date: 08/09/2003 12:16:51
In message <Pine.NEB.4.56.0308090906000.4392@kerry>, Hisashi T Fujinaka writes:
>On Sat, 9 Aug 2003, Steven M. Bellovin wrote:
>> In message <bh2euq$svr$>, Matthias Scheler writes:
>> >In article <>,
>> >	Steve Bellovin <> writes:
>> >> I'm having trouble trying to build a number of different packages that
>> >> depend on libiconv.
>> >
>> >There are two ways to fix this:
>> >1.) Delete the "libiconv" package and rebuild all package depending on it
>> >    because NetBSD-current doesn't need "libiconv" any more.
>> >2.) Set "USE_GNU_ICONV" to "YES" in your environment, use "make clean" and
>> >    retry to build the package.
>> Any ideas on how to accomplish the first one?  libiconv isn't
>> installed; it was properly deleted with the aid of pkgdepgraph.  There
>> are no files in /usr/pkg/lib or /usr/X11R6/lib that contain the string
>> 'iconv'.
>> I could use option 2, but I'd really prefer to get this cleaned up now.
>Any idea if 1) even works? I just deleted converters/libiconv and then
>tried to make abiword and I get:
>checking iconv.h usability... yes
>checking iconv.h presence... yes
>checking for iconv.h... yes
>configure: error: (usable) libiconv not found
>*** Error code 1
>Just like I used to before I installed converters/libiconv.

It hasn't worked for me -- reinstalling libiconv was, of course, the 
first thing I tried.

		--Steve Bellovin,