Subject: Re: Today's build fails 31 July
To: Patrick Welche <>
From: walt <>
List: current-users
Date: 07/31/2003 14:26:58
Patrick Welche wrote:
> On Thu, Jul 31, 2003 at 04:02:23PM -0700, walt wrote:
>>I've never seen this error before.  There is plenty of physical RAM
>>in the machine, so that is not the problem.
>>/usr/obj//tooldir.NetBSD-1.6U-i386/bin/nbmkdep -f Lint_llabs.d 
>>-D_REENTRANT -I/usr/
>>-DI18NMODULE_MAJOR=4 -I/usr/src/libexec/ld.elf_so 
>>-I/usr/src/lib/libc/dlfcn -DCITRUS_ICONV -DWITH_RUNE -I/usr/src/lib/libc 
>>/usr/obj//destdir.i386/usr/include   /usr/src/lib/libc/stdlib/Lint_llabs.c
>>nbmake: Cannot allocate memory.
>>*** Error code 2
> I saw this for the first time today too. Typing "unlimit" at my csh prompt
> and remaking the build allowed to finish..

Hmm.  Interesting.  I'm a bit puzzled because I tried typing 'ulimit' at a
csh prompt and got "command not found'.

When I switched to bash and typed 'ulimit' I got "unlimited' as a response,
but still got the same error when compiling 'distribution'.

Are you sure you are running csh?  Remember, uses 'sh' as a shell.

And what command, exactly, did you use to recompile the system?  Did you
use /usr/src/ or something else?