Subject: Re: systat segfaults
To: Chris Tribo <>
From: walt <>
List: current-users
Date: 07/28/2003 15:54:54
Chris Tribo wrote:
> On Mon, 28 Jul 2003, walt wrote:
>>$ systat
>>Segmentation fault
>>Anyone else seeing this?  I'm not sure when it started
>>because I haven't tried systat for ages.
> 	Yes, it happens when you run a current kernel on 1.6.1 or 
> outdated current userland. If your kernel and userland are in sync this 
> should not happen. (It really shouldn't happen even if they aren't in 
> sync; but that's another story, and more coding)

Okay!  Thanks for the warning.

Now...if you could give me even a vague hint about what part of userland
is responsible for this problem I'd be very grateful.

I've also been having problems with libkvm apps like xosview and gtop
which other people say are working correctly on -current machines.

I've updated my system multiple times using /usr/src/ and have
updated my source tree to -current a dozen times or more, and yet my
userland is still not quite up to -current, if what you say is correct.

I update like this:
cd /usr
cvs -z3 update -Pd src

Should this not give me the correct sources for -current?

I've also used etcupdate, and postinstall gets run each time I rebuild.
Anything else I should be doing?