Subject: Re: Sysinst coredumps during floppy install
To: David Laight <>
From: walt <>
List: current-users
Date: 07/27/2003 13:17:10
David Laight wrote:

 > walt wrote:

>>Now that I have the hard disk set up I can reproduce the segfault
>>easily just by retracing my steps and accepting the partition table
>>and disklabel 'as is', then trying to select the source for the 'sets'
>>again.  I get the segfault with either 'ftp' or 'nfs' which are the
>>only options I've tried so far.

> I've not tried NFS (too hard setting up a server), ftp from localhost
> does work.  How far through the menus do you get (after selecting ftp),
> you might just have found a silly bug...

The segfault is immediate upon hitting 'return'.  And BTW there WAS a
systinst.core file in / which was roughly 100KB in size with 300KB
of space left over in the rootfs.  I remember there was about 400KB
of space after deleting the core file.

Another problem to consider:  I also tried booting the floppies on the
machine which made them and I also got the same segfault there, while
trying to 'install' on the existing MetBSD partition.

On both machines I get an error when trying to 'upgrade' from the
floppies.  When I point sysinst at the appropriate partition for
the upgrade it does an fsck of the partition (seems appropriate)
but then aborts the upgrade with an "unable to mount partition wd1a".

When I exit the install menu and drop to a shell prompt I type
'mount' and see that wda1 is in fact mounted r/w on /target
and I can even write a test file to it.

I'm not sure why sysinst thinks that wd1a is not mounted, but it
certainly is mounted.  This may be the root cause of the whole
problem, but I'm not sure how to find out.

>>Well, I don't know how it worked before your new code, but these floppies
>>certainly do boot now and I just made them yesterday.
> The giveaway is the extra line:
> 	NetBSD/i386 ustarfs Primary Bootstrap

Yep, that's what I see.