Subject: Re: Sysinst coredumps during floppy install
To: <>
From: David Laight <>
List: current-users
Date: 07/27/2003 20:19:07
> Now that I have the hard disk set up I can reproduce the segfault
> easily just by retracing my steps and accepting the partition table
> and disklabel 'as is', then trying to select the source for the 'sets'
> again.  I get the segfault with either 'ftp' or 'nfs' which are the
> only options I've tried so far.

I've not tried NFS (too hard setting up a server), ftp from localhost
does work.  How far through the menus do you get (after selecting ftp),
you might just have found a silly bug...

> Any suggestions for debugging?

I see two possibilities:
1) create a memfs filessytem, and run sysinst from it.
   That ought to make it possible to save the coredump.
2) If wd0 is your build system, build distrib/utils/sysinst and
   try to run through the install running that version.
   (nbmake obj; nbmake depend; nbmake; and run arch/i386/sysinst)

> Well, I don't know how it worked before your new code, but these floppies
> certainly do boot now and I just made them yesterday.

The giveaway is the extra line:

	NetBSD/i386 ustarfs Primary Bootstrap


David Laight: