Subject: Re: build failure in current, error 1 stopped in /usr/src/usr.bin/kdump.
To: Byron Duncan <>
From: David Laight <>
List: current-users
Date: 07/17/2003 17:22:40
On Thu, Jul 17, 2003 at 10:49:10AM -0500, Byron Duncan wrote:
> Hi all I am having problems building current. The build process runs for
> about 3 ½ hours and fails with error 1 stop in /usr/src/usr.bin/kdump.
> That’s all of it no more messages to indicate what the problem is. The
> build system is a pws 600au 1500mg ram 9gb hard drive running 1.6.1
> alpha
> >>From iso images downloaded from netbsd main site. The current source was
> also downloaded from the same sit. I followed the instructions in the
> Howto’s to build the tools tree and then build the new kernel and
> install it. Then I tried to build the distribution and it failed as I
> said above.
> These are the commands I used as per howto instructions. 1 ./
> tools success 2 ./ kernel=GENERIC success installed kernel
> Rebooted and then 3 ./ distribution failed ! I tried it twice
> with the same results and with the 3 ½ hour build times I Came to the
> not
> so quick conclusion that I need help anybody have any ideas PLEASE!!! 

1) I'd use ' -u' to do rebuilds, then it will only take a few
   I suspect you also want to add -U and build as non-root.

2) If you sort out what was used for 'tooldir' you can try rebuilding a
   single program by doing (eg):
   $ cd /usr/src/usr.bin/kdump
   $ $TOOLDIR/nbmake-i386

3) I did change kdump yesterday, it is possible that your source tree
   isn't entirely consistent.  However there ought too be some indication
   of a failure (eg a compiler error message) as well.

   It is best to cut/paste the few lines of the terminal output just
   before the error, gives people a chance of guessing what's wrong.


David Laight: