Subject: Re: port-i386/22096: i386 bootblocks are incompatible with older mainboards
To: None <>
From: David Laight <>
List: current-users
Date: 07/10/2003 09:57:28
> > 1) Are you using /usr/sbin/installboot or /usr/mdec/installboot ?
> I used "/usr/mdec/installboot" like this:
> cd /usr/mdec
> ./installboot biosboot.sym /dev/rwd0a

Ok, so you are installing the 'old' bootblocks :-)
These haven't changed much, if at all.

> But I don't think it is a problem with "installboot". NetBSD was booting
> fine from that harddisk until the Intel motherboard broke. So I put in
> my older ASUS CUBX motherboard and NetBSD didn't boot anymore. I booted
> from a NetBSD 1.6.1 floppy (which worked fine), rewrote the bootblock
> as described above but it didn't help.

Ok, so you actually moved an installed hard disk to different system :-)
It is mossiblt that something in the MBR was wrong (eg the two BIOSs
using different CHS limits).

> So I finally decide to install
> NetBSD 1.6.1_STABLE - the version which I've used on that motherboard
> until last weekend - boot blocks and the problem went away.

Can you try the 'current' bootblocks again?
Otherwise it is impossible to work out why they don't work.

> So I'm quite
> sure that it is a problem with NetBSD-current's boot blocks. They seem
> to work on some motherboards but not on all which worked before.

What you need to try on current is the 'new' bootblocks. Do:
# /sbin/installboot /dev/rwd0a /usr/mdec/bootxx_ufsv1
# cp /usr/mdec/biosboot /boot

> > 2) What was the last message that was actually output?
> The boot block doesn't output anything.

That is, in itself, interesting and important information.

> The last message appearing on the
> screen is XFDisk (my boot selector) saying that it boots NetBSD. I've also
> removed XFDisk once in which case the BIOS said "invalid operating system".

The BIOS won't say "invalid operating system", that would come from the
MBR code.


David Laight: