Subject: Re: port-i386/22096: i386 bootblocks are incompatible with older mainboards
To: None <>
From: Matthias Scheler <>
List: current-users
Date: 07/10/2003 08:21:17
In article <>,
	David Laight <> writes:
>> cpu0: Intel Celeron (686-class), 1102.56 MHz, id 0x68a
> Thats not older :-)

It's older than the ASUS P4B266 and the Intel B865PERLK which both worked
with NetBSD-current's boot blocks, see below.

> Some questions:
> 1) Are you using /usr/sbin/installboot or /usr/mdec/installboot ?

I used "/usr/mdec/installboot" like this:

cd /usr/mdec
./installboot biosboot.sym /dev/rwd0a

But I don't think it is a problem with "installboot". NetBSD was booting
fine from that harddisk until the Intel motherboard broke. So I put in
my older ASUS CUBX motherboard and NetBSD didn't boot anymore. I booted
from a NetBSD 1.6.1 floppy (which worked fine), rewrote the bootblock
as described above but it didn't help. So I finally decide to install
NetBSD 1.6.1_STABLE - the version which I've used on that motherboard
until last weekend - boot blocks and the problem went away. So I'm quite
sure that it is a problem with NetBSD-current's boot blocks. They seem
to work on some motherboards but not on all which worked before.

> 2) What was the last message that was actually output?

The boot block doesn't output anything. The last message appearing on the
screen is XFDisk (my boot selector) saying that it boots NetBSD. I've also
removed XFDisk once in which case the BIOS said "invalid operating system".

[BTW: I don't think it's the ASUS CUBX's fault. I've used that motherboard
 with NetBSD (and XFDisk) for ages and I never had problems.]

	Kind regards

Matthias Scheler