Subject: SiS pciide timeout
To: None <,>
From: Christopher Vance <>
List: current-users
Date: 07/08/2003 22:04:51
I have an Elite P4S5A/DX+ motherboard with an SiS 5513 pciide on it
(and a Pentium 4 and other stuff....).  FreeBSD -current calls this
device a SiS 96X, and its pci identification is 5513 1039.

I just received a 1.6.1 install disk (thanks AUUG), and thought it was
time to install NetBSD on this machine.  I have had a partition set
aside waiting for a while.  :-)

I have run -current in the past on a different machine and was planning
to update to -current.

When I boot from the 1.6.1 CD I get a hang with the last gasp being

pciide0:0:0: lost interrupt
	type: ata tc_bcount: 512 tc_skip: 0
pciide0:0:0: bus-master DMA error: missing interrupt, status=0x61

In the past, both FreeBSD and OpenBSD booted only when dma was
disabled, but both now boot fine with dma enabled (that's -current for
each, haven't tried -stable on either).

Is this a known problem, already fixed in NetBSD-current, or do I need
to run with dma disabled?  Is the answer different for -current vs

I tried booting from NetBSD -current snapshot install floppies in
April, but found no way in the kernel boot-time configuration to set
the flag to disable dma, and otherwise had similar problems.

Is 20030305-1.6P the latest snapshot for i386?

Is compilation of a custom install kernel the only way to install at

Does cross-building hosted on either FreeBSD or OpenBSD currently work
(didn't in April on FreeBSD)?

Or should I come back in a few months when there's another -current

Christopher Vance