Subject: No virtual terminals?
To: None <>
From: walt <>
List: current-users
Date: 07/06/2003 01:21:36
I just updated a PC from 1.6 to 'current' and I see just one minor
problem I need to fix:

The only login prompt I get is on the console.  Using the Ctrl-Alt-Fx
keys gets me only black screens with a cursor in the upper left corner.

When X is running it is accessed with Ctrl-Alt-F2 and the (only) virtual
terminal is the console at Ctrl-Alt-F1.

/etc and /dev are up to date, and /etc/ttys and /etc/ttyaction are
both present.  There are NO gettys running in the background, which
I assume is the problem.

When I type /usr/libexec/getty Pc ttyE2 (or any other tty for that
matter) I get a login prompt on the same console instead of on the
appropriate virtual terminal.  (I don't know if this normally works
or not.  I never tried it before.)

I tried with and without wscons=YES in rc.conf and neither fixes the
problem, although I do see messages about setting up the screens
during boot if use wscons=YES.

What sort of things should I be checking?

Thanks for any ideas.