Subject: Re: Problem Building 06/27/2003 Source
To: Toru TAKAMIZU <>
From: Bryan Vyhmeister <>
List: current-users
Date: 07/04/2003 10:35:02
On Fri, Jul 04, 2003 at 10:13:56PM +0900, Toru TAKAMIZU wrote:
> Thu, Jul 03, 2003 at 10:42:09PM -0700
> Bryan Vyhmeister wrote:
> > #!/bin/sh
> > export CVS_RSH=ssh
> > export
> > cd /usr/src
> > cvs update -dP -D 20030627-UTC
> > 
> > According to my understanding, this would check out sources from 
> > 06/27/2003 00:00:00 UTC. Is that correct? I also tried updating using 
> > the above script with this change just in case the above was not 
> > correct:
> > 
> > cvs update -dP -D "2003-06-27 00:00 UTC"
> You seem to be slightly confused. "checkout" is for the first time and
> "update" after the "checkout". About "-D ...", at least the second
> one is right. I have not tried the first "-D 20030627-UTC" format.
> Anyway, you can check it by "cat /usr/src/CVS/Tag".

I should have been more clear. I have already checked out a tree. I am just 
trying to update it. Thank you for the clarification on the date. Thanks 
for the information on where I can check the tag!

> > I have also been wondering if using a command like the above can back a 
> > tree to that date. In other words, if I have a tree with 07/02/2003 
> > sources, can the above command take my tree back to 06/27/2003 sources, 
> > or do I need to check out a new tree from scratch?
> You don't need to check out from scratch. -D "anytime" is what you need.
> So in your case, 
> 	cvs update -dP -D "2003-06-27 00:00 UTC"
> under /usr/src. "man cvs" for more details.

That's good to know. Thank you.

> > After checking out the sources, I tried building release several times 
> > with the build stopping each time while building tools with the 
> > following error:
> <snip>
> > Any idea what I am doing wrong? Thank you for your help.
> Seemingly you are doing right. As you pointed out,
> implies that you can build from the source of this date.
> But why don't you specify another date?

I tried updating to 2003-07-02 sources and I got the same tools error. I am 
going to try to update again and see what happens. Theoretically, it should 
be fine to build current on a 1.6.1 system, right? I am now trying the 
build on a current system but I was able to build just fine on 1.6.1 
previously. Thank you for your help.