Subject: Re: Using, a question
To: Luke Mewburn <>
From: Brian Buhrow <>
List: current-users
Date: 05/22/2003 23:41:47
	Hi Luke.  I'm now wondering if the cvs server is giving bad data to
the users who get it via anonymous cvs.  the reason is that I completely
wiped out my /var/tmp/netbsd (release [DESTDIR] directory), /usr/obj, and
then, using:
as my cvs root, I did:
cvs checkout src/

This went through and created the entire source tree.  However, it created
some additional directories which appear to be extraneous:
src/usr.bin/ktrace/ktrace (is a directory not a file)
src/usr.bin/man/man (is a directory, not a file)
src/usr.sbin/mrouted/mrouted (is a directory, not a file)

This caused the script to fail during the cleaning phase, because
it expected to remove files, not directories.  Each of the extraneous
directories listed above contained a single "CVS" directory, and that was
it.  Removing them manually allows the build process to continue, but I
wonder if I'm working from a different tree than you are?

	As to the actual build command I run it's:
#cd /usr/src
#./ -M /usr/obj -D /var/tmp/netbsd release >& build.log

Am I doing something wrong?

On May 23,  9:47am, Luke Mewburn wrote:
} Subject: Re: Using, a question
} On Thu, May 22, 2003 at 11:05:49AM -0700, Brian Buhrow wrote:
}   | 	Hi Luke.  the problem I've run into is that the build process can't
}   | build the rescue directory or the floppies, which are both crunched binary
}   | sets, because rcorder, chown and chgrp are unbuilt at the time they're
}   | called upon. My hackish fix was to comment those programs out of
}   | /usr/src/rescue/list, at which point, all built.  However, this is not the
}   | correct fix, and this has been broken for at least two weeks.  You are
}   | correct that I should not use -e with the script, since I'm sure I
}   | know less about the tool chain than you do.  So, is anyone else seeing this
}   | problem and, if so, do they have a fix?
} I haven't seen this problem, and I've built a full distribution and a
} full release on multiple occasions recently, from "up to date"
} sources.
} What's the exact command you're running?
} Are you sources up to date?
} Have you tried using a fresh (clean) "tools", "obj", and "destdir"
} (if you use any of those)?
} Luke.
>-- End of excerpt from Luke Mewburn