Subject: Deprecated calls from gdb to libbfd
To: #List NetBSD current users <current-users@NetBSD.ORG>
From: Paul Goyette <>
List: current-users
Date: 05/18/2003 11:19:54
I've just finished installing 1.6Q-i386 from March 30th sources, and
now whenever I try to use gdb, I get error messages

pc1:sources {231} gdb POP
GNU gdb 5.0nb1
Copyright 2000 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386--netbsdelf"...Deprecated bfd_read called at
/usr/src/gnu/dist/toolchain/gdb/dbxread.c line 2638 in elfstab_build_psymtabs
Deprecated bfd_read called at /usr/src/gnu/dist/toolchain/gdb/dbxread.c line
976 in fill_symbuf


I've tried rebuilding gdb as well as rebuilding libbfd, but the messages

Anyone got any idea how to get rid of them?

|   Paul Goyette   | PGP DSS Key fingerprint: |  E-mail addresses:   |
| Network Engineer | 9DC5 05CF 1AE7 DC42 CCC6 |   |
|  & World Cruiser | 6858 051E 7AD2 A6B2 4954 | |