Subject: Re: 20030420 build fails
To: Ben Harris <>
From: John Nemeth <>
List: current-users
Date: 04/22/2003 01:29:37
On Sep 11,  1:05pm, Ben Harris wrote:
} In article <> you write:
} >     I just tried to build -current (cvs update'd immediately before I
} >started), and I bombed with the following:
} >
} >/mnt/NetBSD-current/destdir/lib/ ->
} >/mnt/NetBSD-current/destdirstopped -> nbmake:
} >/mnt/NetBSD-current/destdir/mnt/NetBSD-current/src/lib/libdes. -> in
} >nbinstall: /mnt/NetBSD-current/destdir/mnt/NetBSD-current/src/lib: mktemp: No su
} >ch file or directory
} >*** Error code 1
} >
} >Stop.
} >nbmake: stopped in /mnt/NetBSD-current/src/lib/libcrypto
} It bit me too.  I think this is the right fix, but perhaps someone who
} understands the insides of should look at it:

     I tried your patch.  It seems to work, since the build got much
further along.  However, now I have a problem with one of the disk
images being too big:

Creating image into ramdisk-small.fs...
rm -f ramdisk-small.fs ramdisk-small.fs.tmp
/mnt/NetBSD-current/src/tools/obj/tools.NetBSD-1.6_RC1-i386/bin/nbmakefs -t ffs
-B le -s 1600k -F work.spec  -N /mnt/NetBSD-current/src/etc -o bsize=4096,fsize=
512  -o optimization=space,minfree=0  -f 14 ramdisk-small.fs.tmp work  && mv -f
ramdisk-small.fs.tmp ramdisk-small.fs
nbmakefs: `work' size of 1658880 is larger than the maxsize of 1638400.
*** Error code 1

}-- End of excerpt from Ben Harris