Subject: Re: DVD drive not working
To: None <>
From: Soren Jacobsen <>
List: current-users
Date: 04/15/2003 13:29:20
On Tue, Apr 15, 2003 at 09:35:46PM +0200, Manuel Bouyer wrote:
> On Mon, Apr 14, 2003 at 07:11:03PM -0700, Soren Jacobsen wrote:
> > I've been putting off asking this, as I thought it might have been an
> > actual hardware error, but I just tried to use this drive with 1.6.1 and
> > it worked flawlessly. Under today's current (and since a few weeks ago)
> > I get the following if I try to use the drive (play a DVD, mount a
> > CD-ROM):
> > cd0(pciide0:1:0): non-media hardware failure, data = 00 00 00 00 08 03
> > 00 00 00 00
> > 
> > Here is the relevant dmesg info:
> Is it from current or 1.6.1 ? Can you also post the dmesg from the other
> kernel ?

Someone suggested in private mail that I take UDMA modes into
consideration, and perhaps try forcing the drive to a lower mode. That
reminded me that I have an old IDE cable connected to that drive, so of
course the drive can't be used at UDMA/66. I had also forgotten that
1.6.1 has no DMA support for nforce2, and so it wasn't using DMA at all,
which explains why I didn't have any problems in 1.6.1. So I
sprinklked some flags 0xaac, and that will work until I get a new

This, and other DMA related issues I've heard of, makes me wonder if
flags 0x0000 is a good idea in INSTALL kernels.

Soren Jacobsen