Subject: Re: Horrible RAIDFrame Crash
To: None <>
From: Caffeinate The World <>
List: current-users
Date: 04/15/2003 03:51:51
I have more info. I used a camcorder to record the scrolling and put it
on frame pause to get some info (only a corner of the screen, had to
zoom otherwise I couldn't read the small blurred text):

fd0 at...
mclock0 at isa0 port...
Kernelized RAIDframe activated
scsibus0: waiting 2 seconds for device...
sd0 at scsibus0 target 1 lun 0: ...
sd0: 8683 MB, 5268 cyl...
sd0: sync (50.0ns ...
sd1 at scsibus0 target 2 lun 0: ...
sd1: 8683 MB, 5268 cyl...
sd1: sync (50.0ns offset 8), ...
raid0: RAID Level 1
raid0: Components: /dev/sd0a /dev/sd1a...[screen cutoff]
raid0: Total Sectors: 1023872 (499 MB)...
raid1: RAID Level 1
raid1: Components: component0[**FAILED*...
raid1: Total Sectors: 1023872 (499 MB)...
raid2: RAID Level 1
raid2: Components: component0[**FAILED*...
raid2: Total Sectors: 10485632 (5119 MB)...
raid3: RAID Level 1
raid3: Components: component0[**FAILED**...
raid3: Total Sectors;: 5249280 (2563 MB)...
root on raid0a dumps on raid0b 
  NOTE: no such raid0b
root file system type: ffs
warning: no /dev/console
exec /sbin/initi: error 20
init: trying /sbin/oinit
exec /sbin/oinit: error 20
init: trying /sbin/init.bak
exec /sbin/init.bak: error 20
init: not found
panic: no init
syncing disks... done

--- Caffeinate The World <> wrote:
> Alpha 1.6R CVS src from 4/13.
> I was trying to build a raid1 set using sd0 and sd1. sd0 that had
> live
> data on it. I succeeded in creating a temporary set using sd1 and a
> fake nonexisting first component. 
> sd1a raid0 /
> sd1b raid1 swap
> sd1d raid2 /var
> sd1e raid3 /usr
> installboot was used on sd1c. During reboot, I told the alpha to boot
> from dkc200 where sd1 lived. It booted up fine with the regular
> warnings regarding the fake component.
> Then I disklabel sd0 with an exact duplicate of sd1 disklabel with
> only
>  the "disk:" field in the disklabel different. installboot on sd0c
> went
> fine.
> Then I tried to:
> raidctl -a /dev/sd0a raid0 
> raidctl -vF component0 raid0
> ... all hell broke ...
> I head a louder than usual 2 second grinding noise from the HDs in
> the
> alpha. Then errors scrolled so fast I couldn't see. But I did see:
> Multiple disks failed in a single group!  Aborting I/O operation.
> The alpha rebooted itself. I told it to use dkc200 (sd1) to boot
> from.
> 1st and 2nd boot stage went fine. kernel was showing dmesg.. it
> showed
> the SCSI drives sd0 and sd1.. then it showed the line:
> Kernelized RAIDFrame activated
> ... bunch  of fast scrolling errors that I couldn't see ...
> I was able to ctrl-c out to >>> and toward the top it said not able
> to
> find init.. and it tried to find init.bak but couldn't.
> My questions:
> 1. is my data gone?
> 2. anyway to get the raid to boot again? ie. fix this problem?
> 3. is this a nasty bug?
> 4. anyway to pause the screen from scrolling?
> Thomas
> __________________________________________________
> Do you Yahoo!?
> The New Yahoo! Search - Faster. Easier. Bingo

Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo