Subject: DVD drive not working
To: None <>
From: Soren Jacobsen <>
List: current-users
Date: 04/14/2003 19:11:03
I've been putting off asking this, as I thought it might have been an
actual hardware error, but I just tried to use this drive with 1.6.1 and
it worked flawlessly. Under today's current (and since a few weeks ago)
I get the following if I try to use the drive (play a DVD, mount a
cd0(pciide0:1:0): non-media hardware failure, data = 00 00 00 00 08 03
00 00 00 00

Here is the relevant dmesg info:
pciide0 at pci0 dev 9 function 0: NVIDIA nForce2 IDE Controller (rev.
pciide0: bus-master DMA support present
pciide0: secondary channel configured to compatibility mode
atapibus0 at pciide0 channel 1: 2 targets
cd0 at atapibus0 drive 0: <Pioneer DVD-ROM ATAPIModel DVD-106S 012, ,
E1.22> cdrom removable
cd0: 32-bit data port
cd0: drive supports PIO mode 4, DMA mode 2, Ultra-DMA mode 4 (Ultra/66)
pciide0: secondary channel interrupting at irq 15
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 4 (Ultra/66) (using
DMA data transfers)

I'd appreciate it if anyone has an idea of what's wrong, or tips on how
to debug this.

Soren Jacobsen