Subject: problems with builtin sound & LAN on ASUS A7M266-M (HP OEM)
To: None <>
From: Laine Stump <>
List: current-users
Date: 04/14/2003 13:47:43
I'm having a couple of problems with the integrated peripherals on this motherboard, one that's existed since I first tried -current on it (about 9 months ago), the other that's cropped up since then. Both of these pieces of hardware work properly under Win2k, so I'm fairly certain it's not a hardware failure. All the below experimentation was done with -current as of yesterday or the day before.

1) Audio - this problem always existed

The audio is detected like this:

  auvia0 at pci0 dev 4 function 5: VIA VT82C686A AC'97 Audio (rev 0x50)
  auvia0: interrupting at irq 10
  auvia0: Crystal CS4299 codec; headphone, 20 bit DAC, 18 bit ADC, Crystal Semi 3D
  auvia0: variable rate audio
  audio0 at auvia0: full duplex, mmap, independent

When I run mpg123 on an mp3 file, I just get a high pitched "tlink!" sound as it starts, then a much softer "tick tick tick tick" as it continues to play. No other sound.

I know this codec is problematic, as I couldn't make it work with WinME, for example, but operation under Win2k shows it is capable of producing sound.

Any suggestions?

2) LAN - this worked (albeit with extremely poor performance) when I first tried -current 9 months ago, then stopped working sometime last Winter (or maybe Fall)

The onboard LAN is detected:

  rtk0 at pci0 dev 18 function 0: RealTek 8139 10/100BaseTX
  rtk0: interrupting at irq 5
  rtk0: Ethernet address 00:e0:18:34:b0:b4
  ukphy0 at rtk0 phy 7: Generic IEEE 802.3u media interface
  ukphy0: OUI 0x000000, model 0x0000, rev. 0
  ukphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto

As soon as I try running dhclient on the interface, I begin seeing

	rtk0: watchdog timeout

in the dmesg, and it's never able to get an address. ifconfig shows that the type of switch is properly autodetected (100baseTX full-duplex), but tcpdump on another machine on the network doesn't show any packets from this machine, and tcpdump on this machine doesn't show any broadcast traffic either - apparently it is neither sending nor receiving packets.

Here's the full dmesg output in case it might provide some other clue: