Subject: Nightmare File Corruptions with 1.6Q - FFS?
To: None <>
From: Joseph Sarkes <>
List: current-users
Date: 04/11/2003 18:56:06
From: Joseph Sarkes <>
Date: Fri Apr 11, 2003  6:53:46 PM US/Eastern
To: Caffeinate The World <>
Subject: Re: Nightmare File Corruptions with 1.6Q - FFS?

On Friday, April 11, 2003, at 12:03 PM, Caffeinate The World wrote:

> It's been a nightmare after upgrading to 1.6Q.
> I believe the recent code change to FFS is causing these issues to pop
> up. I'm seeing file corruptions. When a library gets corrupted, things
> will fail.
> I saw these corruptions (was reported to the list) when I tried to make
> install world. I manually got pass that phase.

I may have a related problem to this on a macppc running a -current 
from yesterday. After a reboot I get can't fsk, run fsk manually due to 
between the superblock and its backup. fsck can't fix it (my base 
system is from
an october -current, which I haven't been able to build -current to 
and get stable operation since.

Anyways, booting the old kernel has the same complaints now, and I
don't know how to resync the superblocks. Manually mounting the 
worked, and my system seems stable, but... what happened? the fsck -b 
isn't around but is referenced somewhere. fsdb doesn't seem to have 
available to check this out either. hmmm,

If all else fails, I will start over with a totally new install.