Subject: Re: gcc-3.2.2 and NetBSD-1.6Q
To: None <>
From: Caffeinate The World <>
List: current-users
Date: 04/05/2003 22:26:38
--- Christian Biere <> wrote:
> Caffeinate The World <> wrote:
> > Just a note to anyone else who uses gcc-3.2.2 under NetBSD-1.6 and
> is
> > thinking of upgrading to NetBSD-1.6Q.

I had to look that up!

> > You'll have to recompile  gcc-3.2.2 from package after your
> upgrade,
> > otherwise you'll get some errors during "make" operations of
> > applications.
> What errors? Which applications?

Trying to compile freevrrpd (NetBSD version). I don't remember exactly
what the error was but it complained about some mismatching {} from
some system include files.

After commenting out "include /usr/pkg/etc/" from
"/etc/mk.conf" and verifying that compile works under native gcc-2.95.3
under 1.6Q, I "make update" gcc-3.2.2.

Added "include /usr/pkg/etc/" back in "/etc/mk.conf" and
recompiled freevrrpd-0.8.6. There were no errors.

freevrrpd-0.8.6 compiled fine under 1.6 and gcc-3.2.2 before I upgraded
to 1.6Q.

Sorry I don't have more specific errors to give. I'll dump the errors
out to a file next time.


Do you Yahoo!?
Yahoo! Tax Center - File online, calculators, forms, and more