Subject: Re: panic: ffs_write: type
To: None <>
From: Caffeinate The World <>
List: current-users
Date: 04/05/2003 11:04:27
--- Caffeinate The World <> wrote:
> While upgrading from 1.6 to -current I received the following error:
> ./ -D /var/build/alpha \
>            -O /var/build/alpha-obj \
>            -T /var/build/alpha-tools \
>            install=/
> ...
> Copying set base
> pax: unable to obtain block size for file /./sbin/mbrlabel (bad file
> discriptor)
> panic: ffs_write: type
> syncing disks...

The system locked up at "syncing disks..." Upon pressing the reset
button, the system boot up, but drop out at fsck with a notice to do
fsck manually.

# fsck /dev/rsd0a
  Answered 'y' to questions

# fsck /dev/rsd0d
  Answered 'y' to questions

Reboot and let it boot up completely. Then tried install
command above again.  Same error and additional ones I didn't write
down. The system rebooted itself and said it had some problems finding and wouldn't allow /bin/sh to load and asked me to
choose a different shell. I typed /bin/ksh and got the root prompt.

Some of the needed libraries were wiped out or render useless during intall above. At this point If I tried to copy from
/var/build/alpha/lib/* to /lib so I can get some of the basic libraries
back. During the copying it got "stuck." Didn't do anything and locked

Upon pressing the reset button, the system boot up pass the Alpha boot
sequence and reboot itself in a loop. It all happened really fast but I
got a glimpse about "init" not able to start. 

I knew I couldn't use any binaries or libraries that's on /dev/sd0a
mounted on /. Booting from two 1.6 install floppies, I exit to shell. 

- fsck the partitions. 
- mount /dev/sd0a on /mnt
- mount /dev/sd0d on /mnt/var
- cd /mnt/var/build/alpha. cd to each directory except 
  for etc and var and "pax -rw -pe . /mnt/<dirname>"
- sync; sync; reboot

Now everything is running again. I wanted to test some of the
applications that used pth pthread and use NetBSD's new native threads.
Upown compiling, it couldn't find 'pthread.h'. I thought that to be
very strange because:

  cd /mnt/var/build/alpha/usr
  pax -rw -pe . /mnt/usr

would have copied the whole tree under /mnt/var/build/alpha/usr to
/usr. That wasn't the case. I 'ls -l /usr/include' and didn't see the
needed pthread headers and the file stamps where from last year and not
from when I build world (yesterday).

I tried the install process again:

 ./ -D /var/build/alpha \
            -O /var/build/alpha-obj \
            -T /var/build/alpha-tools \

This time it finished without any problems and no dreaded 'panic:
ffs_write: type' errors. sync; sync; reboot just to be sure. The system
has been running fine since.


Do you Yahoo!?
Yahoo! Tax Center - File online, calculators, forms, and more