Subject: Re: server bind failure 48: Address already in use
To: None <>
From: Caffeinate The World <>
List: current-users
Date: 04/05/2003 00:56:54
--- Caffeinate The World <> wrote:
> I just compiled one of my chat app with NetBSD 1.6Q native pthread
> (changed from pth). However, now when I start the daemon which runs
> on
> port 6666, it says:
> server bind failure 48: Address already in use
> It gives that error only when run as a non-priviledged user. However,
> if I run it under my username (am in group wheel) or under root, then
> it starts fine.

I ran it under gdb and got:

nbsd_thread_create_inferior: td_open: process callback error
(gdb) bt
warning: Hit beginning of text section without finding
warning: enclosing function for address 0x18
This warning occurs if you are debugging a function without any symbols
(for example, in a stripped executable).  In that case, you may wish to
increase the size of the search with the `set heuristic-fence-post'

Otherwise, you told GDB there was a function where there isn't one, or
(more likely) you have encountered a bug in GDB.
#0  0x18 in ?? ()
Error accessing memory address 0xfffffffffffffffd: Operation not
(gdb) c
warning: Cannot insert breakpoint -2:
warning: Temporarily disabling shared library breakpoints:
warning: breakpoint #-2
[tcsetpgrp failed in terminal_inferior: Invalid argument]
ptrace: Operation not permitted.
[Switching to LWP 0]

No idea what that means.


Do you Yahoo!?
Yahoo! Tax Center - File online, calculators, forms, and more