Subject: Building userland fails in bin/pax
To: NetBSD-current-users <>
From: Matthias Redlich <>
List: current-users
Date: 03/01/2003 18:29:26
Hi folks,

I wanted to install NetBSD-current yesterday. After updating my sources
I succesfully did the following steps: './ tools','./
kernel=<MYKERNEL>', replaced /netbsd with the new kernel, rebooted.

Then I wanted to build the new userland. I tried './ -u -D "" -T
/usr/tools -M /usr/obj distribution' (DESTDIR is an empty string because
I want to replace my old system). It stopped with the following error:

<installing stuff from /usr/src/bin..>
install ==> bin/pax
/usr/src//bin/tar -> /usr/src//bin/pax
*** Error code 1

nbmake: stopped in /usr/src/bin/pax/obj

<leaving dirs..>

/usr/src/bin/tar does not exist.

I do not know what to do because I have no real error message (just
Error code 1). Does anybody know this problem? How could I get more

I have already searched the ml archives, but I have only found some
information that tar was replaced by pax or something like that.

I tried on NetBSD 1.6, i386 with sources from yesterday.

Thanks in advance,