Subject: Re: test_popen failed. Compiling Python 2.1.3
To: None <current-users@NetBSD.ORG>
From: MLH <>
List: current-users
Date: 02/11/2003 19:53:35
On 11 Feb 2003 12:35:01 -0600, Matthias Drochner wrote:
> said:
>> I compiled Python-2.1.3.tar.gz (from with no problems.
>> I need a working 2.1.3 version of python with threads in order to install
>> Zope 2.6.1

Jose, have you tried building python21-pth-2.1.3 ?

> As a starting point you could look at pkgsrc/www/zope25.
> The installation procedure shouldn't be too different for 2.6.1;
> just replace the versions in the Makefile...
> Eventually I'll add a zope26 pkg.


1) most of the zope packages that do not require one to compile
shared libraries don't need a particular version of Zope wither
than '2'. Is there really a need to prefix those packages with
zope2x- ?  How about just zope2- ?

2) The old www/zope (zope-2.2.2) that Ty put in pkgsrc is quite
old and likely predates all but a few of us who use zope. I'd almost
be willing to bet that noone is using 2.2.2 on NetBSD anymore.

What about retiring www/zope and www/zope-confera?

I'm working with to wrap up a databases/py-sybase
package for 21pth/22pth that can use either the Sybase Libraries
or FreeTDS (will default to FreeTDS), and an associated Zope DA
package for Sybase databases. What to call the pkgsrc pkg?
zope2-OCSybaseDA ?  :^)