Subject: Phoenix on -current: don't do this...:
To: None <>
From: Martin Weber <>
List: current-users
Date: 01/30/2003 18:53:41
Hmm, yell at me for being dumb but I had phoenix hang up (top showed
something with f in it and close or something like that don't remember)
and thought it would be wise to get rid of the window by shooting it with
xkill (which worked fine, signals were not delivered to it (not even -9!)).
So the window was removed, but hey, phoenix still was in my process list
with state (ps) : DEl (Uninterruptible sleep + tries to exit + > 1 LWP).

So I thought hey, let's attach to it with gdb (bt showed something at an
odd address with a repeating pattern like 0x642642 or sth like that and
moaned he could not access the memory there), and I typed kill. Hit enter.

And this brings me to why I'm so vague about all this :) The machine hung
rock solid... no keyboard input, nothing was processed (tried logging in
via network, of course that failed to).

Pity my attempts to read gdb help on thread listing or something scrolled
the bt off the screen, and you can guess I wouldn't be able to switch to
another screen to look at top & ps to note exactly what they said. Well,
I had to hit the power button.

This is with all sources from yesterday, built yesterday, kernel and userland
in synch, phoenix built yesterday (or at least started building yesterday,
was finished somewhen this noon...).

Any datapoints I can throw at you so you can solve that ?

Thanks in advance,

-Martin Weber