Subject: Re: Failing to build glib
To: None <>
From: Peter Bex <>
List: current-users
Date: 01/29/2003 20:14:51
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Have you tried a ``make clean'' first? Perhaps somehow the file got corrupt=
It shouldn't, but it's a possibility you might want to investigate.

Hope this helps,

On Wed, Jan 29, 2003 at 07:27:20PM +0100, Konrad Neuwirth wrote:
> Hi,
>   I can't get glib to build; I've updated most everything but it
> always gives me the following error:
> | # make
> | =3D=3D=3D> Building for glib-1.2.10nb3
> | make  all-recursive
> | Making all in .
> | Making all in gmodule
> | Making all in gthread
> | /bin/sh ../libtool --mode=3Dlink cc  -O2 -I/usr/pkg/include -Wall  -D_R=
EENTRANT -Wl,-R/usr/pkg/lib -L/usr/pkg/lib -o -rpath /usr/pkg=
/lib -version-info 13:10:0 gthread.lo -lpthread=20
> | libtool: link: `/usr/pkgsrc/devel/glib/work/.buildlink/lib/libpthread.l=
a' is not a valid libtool archive
> | *** Error code 1
> What am I doing wrong?
> Thanks,
>  Konrad

"The process of preparing programs for a digital computer
 is especially attractive, not only because it can be economically
 and scientifically rewarding, but also because it can be an aesthetic
 experience much like composing poetry or music."
							-- Donald Knuth

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.2.1 (NetBSD)