Subject: vs make build
To: None <>
From: Patrick Welche <>
List: current-users
Date: 01/23/2003 14:09:53
I'm assuming that I will be able to build the work if I run, but
if I run "make build", I get the usual problem about missing tool directories
under groff. The bit that intrigues me is in src/tools/groff/Makefile:

# Since ${TMACDIR} is created by the `realinstall' target, the `afterinstall'
# sources below that depend on it must wait until `realinstall' is done.

however, I observe that TMACDIR is not being created at all...
make dependall is fine, make install:
/usr/src/tools/obj.i386/tools.NetBSD-1.6M-i386/bin/nbinstall -c -p -r -m 444 /usr/src/tools/groff/../../share/tmac/andoc /usr/src/tools/obj.i386/tools.NetBSD-1.6M-i386/share/groff/tmac/tmac.andoc
nbinstall: /usr/src/tools/obj.i386/tools.NetBSD-1.6M-i386/share/groff/tmac: mkstemp: No such file or directory


# make -n realinstall
cd /usr/src/tools/groff/obj.i386;  if [ ! -f .install_done ] || [ ! -f .build_done ] ||  [ -n "$(find .build_done -prune -newer .install_done -print)" ]; then  (cd build && make bindir=/usr/src/tools/obj.i386/tools.NetBSD-1.6M-i386/lib/groff _NOWRAPPER=1 BISON=true DESTDIR= INSTALL=/usr/src/tools/obj.i386/tools.NetBSD-1.6M-i386/bin/nbinstall\ -c\ -p\ -r install);  fi
touch .install_done

-rw-r--r--   1 root  wheel     0 Jan 22 18:39 .configure_done
-rw-r--r--   1 root  wheel     0 Jan 23 00:05 .build_done
-rw-r--r--   1 root  wheel     0 Jan 23 13:58 .install_done

After removing .install_done, make install gives the same error message,
so said directory definitely isn't being created.

(The only reason I noticed again, is because it's my first attempt at 1.6M.
Once the directories are created, all is fine until the letter is bumped and
a new tooldir used by default)