Subject: NFS issues on NetBSD
To: None <>
From: D'Arcy J.M. Cain <>
List: current-users
Date: 01/23/2003 06:18:53
I am trying to get NetBSD working with a NetApp.  It works OK for a while but 
if I pound it hard enough it eventually dies.  It appears to get itself 
confused about what has been written to the mounted drive and what hasn't.  
In PostgreSQL, the app that I am using to pound it with, I load a large 
database and the load dies with an error that indicates that the data block 
that was just written cannot be found on the disk.  I tried this with another 
NetBSD machine instead of the NetApp and it worked a little longer but 
eventually failed to load with the same error.

A friend who uses FreeBSD tells me that there were problems in all the BSD NFS 
implementations but that FreeBSD mad a major push and fixed it.  I don't want 
to switch these servers to FreeBSD so I am hoping to find the problems and 
fix them in NetBSD.

Does anyone know of any specific problems with our implementation?  I know 
that I use NFS in many places without any problem but there seems to be an 
issue with super heavy NFS access.  Perhaps it has to do with the way it is 
accessed by PostgreSQL that differs from normal access.  I even use it on my 
ISP for all my user directories without ever a peep but this DB app always 

The folks at NetApp have indicated a willingness to work with me to find the 
problems with the NFS code and possibly even propose patches.  If there is 
someone who knows the NFS code real well that would like to be involved in 
this conversation then please contact me.

According to my friend the FreeBSD people used an NFS test suite that was 
floating around to test their implemtation.  Does anyone know where to find 
this script?

D'Arcy J.M. Cain <>