Subject: Re: Problems with serial console redirection
To: , <>
From: Brian Buhrow <>
List: current-users
Date: 01/17/2003 14:32:12
	Hello David.  Youve probably already gotten many responses on this 
question, so I'll  add my thoughts.
	It sounds like you have the console redirected fine, but you don't
have getty turned on to allow logins on the port once the machine is
booted.  To test this, if you can boot single user, you'll get a prompt to
"type the name of a program or hit return for sh" on the console when it's
about to go into single user mode on the redirected console.  Hit return.
If you get a "#" prompt, then you know you've redirected the console
properly and you just have to figure out 
which port you should enable in /etc/ttys to get login prompts to show up
on the port when the machine is in multiuser mode.  The easiest way I can
think of to do this is to type "tty" at the "#" prompt in single user mode
to get the system to tell you which tty port you're using.  You'll probably
see something like:

Then, edit /etc/ttys and look for the line which matches
your console port.  I.e. if it says, /dev/tty00, look for a line that
begins with tty00.  
Then, make it look like:

tty00	"/usr/libexec/getty std.57600"	unknown	on local secure

This says, run getty on the port, set the baud rate to 57600, do not
require carrier detect to enable the login prompt, and allow root to login
to the port without  a password in single user mode.

	Now, reboot.  When booting is finished, you should be presented
with a login prompt, and should be able to login.
On Jan 17,  1:20am, "David Francheski" wrote:
} Subject: Problems with serial console redirection
} I'm having problems regarding trying to get the serial console 
} redirected properly.
} Our system is a SuperMicro 6022 system.  The BIOS supports "console 
} redirection" as an option for configuration so I enable it, setting the
} com 
} port to A, and use 57.6 baud, vt-100 console type, and various attempts
} at 
} flow control (xon/xoff, rts/cts, none).  I have a serial console
} connection 
} to the system and then configure the NetBSD system.  In the
} configuration I 
} set up the following configuration items in the kernel config file
} before 
} the make (changing the address for the com 0 port of 3f8 instead of
} 2f8):
} # This option allows you to force a serial console at the specified
} # I/O address.   see console(4) for details.
} options    CONSDEVNAME="\"com\"",CONADDR=0x3f8,CONSPEED=57600
} #       you don't want the option below ON if you are using the
} #       serial console option of the new boot strap code.
} options    CONS_OVERRIDE   # Always use above! independent of boot info
} I have tried different tweaks to the wscons.conf but without much luck.
} What happens on boot of the generated kernel is that the console
} messages 
} actually do get redirected to the serial connect (I am connecting
} through a 
} Console Management station which takes the serial port and maps the 
} console/keyboard over) and the messages seem to be echoed out properly.
} The last messages I get on the redirected screen are:
}   Starting sshd
}   Starting inetd
}   Starting cron
}  <a printout of the current date/time >
} then the connection goes dead and all I get are garbage characters on
} the 
} screen, I am expecting that this must be the time wscons takes over for
} the 
} console - and I am getting all the same characters echoed on the screen 
} (alpha character) - but I have no keyboard input and there the data on
} the 
} screen is just garbled.
} Is there a secret to enabling a serial redirected console (some point of
} configuration) that I am missing?  
} Appreciate any helps towards resolving this.
} Regards,
} David L. Francheski
} Caymas Systems, Inc.
} 1179 N. McDowell Blvd., Suite A
} Petaluma, CA 94954
} Phone: 1-707-283-5038
} FAX:    1-707-283-5001
} email:
>-- End of excerpt from "David Francheski"