Subject: Re: Heads up: i386 MP config change
To: Frank van der Linden <fvdl@wasabisystems.com>
From: John Franklin <franklin@elfie.org>
List: current-users
Date: 01/10/2003 14:31:07
--M9NhX3UHpAaciwkO
Content-Type: text/plain; charset=iso-8859-1
Content-Disposition: inline
Content-Transfer-Encoding: 8bit

On Fri, Jan 10, 2003 at 02:09:07PM -0500, John Franklin wrote:
> On Tue, Jan 07, 2003 at 08:01:42PM +0100, Frank van der Linden wrote:
> > I have added code to the i386 port to retrieve MP and interrupt
> > routing info via ACPI. Since this is an alternate method to
> > getting the info from the MP BIOS, I made them both optional.

FYI, the same with MPVERBOSE enabled:

-- 
John Franklin
franklin@elfie.org
ICBM: 3543'56"N 7853'27"W

--M9NhX3UHpAaciwkO
Content-Type: text/plain; charset=us-ascii
Content-Disposition: attachment; filename="dmesg.works"

NetBSD 1.6L (DM.ACPI) #0: Fri Jan 10 14:16:58 EST 2003
    franklin@deathmitten:/usr/src2/sys/arch/i386/compile/DM.ACPI
total memory = 447 MB
avail memory = 322 MB
using 6144 buffers containing 111 MB of memory
BIOS32 rev. 0 found at 0xfb290
mainbus0 (root)
mainbus0: scanning 0x9fc00 to 0x9fff0 for MP signature
mainbus0: scanning 0xf0000 to 0xffff0 for MP signature
mainbus0: MP floating pointer found in bios at 0xf5940
mainbus0: MP config table at 0xf1400, 260 bytes long
 tbxface-0198 [01] AcpiLoadTables        : ACPI Tables successfully acquired
Parsing all Control Methods:
Table [DSDT] - 306 Objects with 26 Devices 75 Methods 19 Regions
ACPI Namespace successfully loaded at root 0xc03405f8


ACPI MADT table:
default local APIC address: fee00000
system dual 8259 present
entries:
processor: id 0 apid 0 enabled: yes
processor: id 1 apid 1 enabled: yes
ioapic: apid 2 address fec00000 vector base 0
int override: bus 0 irq 0 int 2
int override: bus 0 irq 9 int 9
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel Pentium II (Klamath) (686-class), 267.29 MHz, id 0x633
cpu0: features 80fbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR>
cpu0: features 80fbff<PGE,MCA,CMOV,MMX>
cpu0: I-cache 16 KB 32b/line 4-way, D-cache 16 KB 32b/line 4-way
cpu0: L2 cache 512 KB 32b/line 4-way
cpu0: ITLB 32 4 KB entries 4-way, 2 4 MB entries fully associative
cpu0: DTLB 64 4 KB entries 4-way, 8 4 MB entries 4-way
cpu0: calibrating local timer
cpu0: apic clock running at 66 MHz
cpu0: 32 page colors
cpu0: kstack at 0xe15db000 for 16384 bytes
cpu0: idle pcb at 0xe15db000, idle sp at 0xe15def98
cpu1 at mainbus0: apid 1 (application processor)
cpu1: starting
cpu1: Intel Pentium II (Klamath) (686-class), 267.46 MHz, id 0x634
cpu1: features 80fbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR>
cpu1: features 80fbff<PGE,MCA,CMOV,MMX>
cpu1: I-cache 16 KB 32b/line 4-way, D-cache 16 KB 32b/line 4-way
cpu1: L2 cache 512 KB 32b/line 4-way
cpu1: ITLB 32 4 KB entries 4-way, 2 4 MB entries fully associative
cpu1: DTLB 64 4 KB entries 4-way, 8 4 MB entries 4-way
cpu1: kstack at 0xe15e3000 for 16384 bytes
cpu1: idle pcb at 0xe15e3000, idle sp at 0xe15e6f98
ioapic0 at mainbus0 apid 2 (I/O APIC)
ioapic0: pa 0xfec00000, virtual wire mode, version 11, 24 pins
acpi0 at mainbus0
acpi0: X/RSDT: OemId <VIA694,AWRDACPI,42302e31>, AslId <AWRD,00000000>
evxfevnt-0173 [02] AcpiEnable            : Transition to ACPI mode successful
acpi0: SCI interrupting at irq 9
acpi0: fixed-feature power button present
acpi_pci_fixup starts:
acpi0: fixing up PCI bus 0 at level 1
acpi0: fixing up intr link \_SB_.PCI0.LNKC
rscreate-0439 [05] RsCreatePciRoutingTabl: (PRT[18].SourceIndex) Need Integer, found Reference
mpacpi: 0 PCI busses


ACPI MADT table:
default local APIC address: fee00000
system dual 8259 present
entries:
processor: id 0 apid 0 enabled: yes
processor: id 1 apid 1 enabled: yes
ioapic: apid 2 address fec00000 vector base 0
int override: bus 0 irq 0 int 2
int override: bus 0 irq 9 int 9
ioapic0: int2 attached to isa0 irq 0 (type 0<type=0> flags 0<pol=0,trig=0>)
ioapic0: int1 attached to isa0 irq 1 (type 0<type=0> flags 0<pol=0,trig=0>)
ioapic0: int3 attached to isa0 irq 3 (type 0<type=0> flags 0<pol=0,trig=0>)
ioapic0: int4 attached to isa0 irq 4 (type 0<type=0> flags 0<pol=0,trig=0>)
ioapic0: int5 attached to isa0 irq 5 (type 0<type=0> flags 0<pol=0,trig=0>)
ioapic0: int6 attached to isa0 irq 6 (type 0<type=0> flags 0<pol=0,trig=0>)
ioapic0: int7 attached to isa0 irq 7 (type 0<type=0> flags 0<pol=0,trig=0>)
ioapic0: int8 attached to isa0 irq 8 (type 0<type=0> flags 0<pol=0,trig=0>)
ioapic0: int9 attached to isa0 irq 9 (type 0<type=0> flags 0<pol=0,trig=0>)
ioapic0: int10 attached to isa0 irq 10 (type 0<type=0> flags 0<pol=0,trig=0>)
ioapic0: int11 attached to isa0 irq 11 (type 0<type=0> flags 0<pol=0,trig=0>)
ioapic0: int12 attached to isa0 irq 12 (type 0<type=0> flags 0<pol=0,trig=0>)
ioapic0: int13 attached to isa0 irq 13 (type 0<type=0> flags 0<pol=0,trig=0>)
ioapic0: int14 attached to isa0 irq 14 (type 0<type=0> flags 0<pol=0,trig=0>)
ioapic0: int15 attached to isa0 irq 15 (type 0<type=0> flags 0<pol=0,trig=0>)
ACPI Object Type 'Processor' (0x0c) at acpi0 not configured
ACPI Object Type 'Processor' (0x0c) at acpi0 not configured
acpibut0 at acpi0 (PNP0C0C): ACPI Power Button
PNP0C01 [System Board] at acpi0 not configured
PNP0A03 [PCI Bus] at acpi0 not configured
PNP0C0F [PCI interrupt link device] at acpi0 not configured
PNP0C0F [PCI interrupt link device] at acpi0 not configured
PNP0C0F [PCI interrupt link device] at acpi0 not configured
PNP0C0F [PCI interrupt link device] at acpi0 not configured
PNP0C02 [Plug and Play motherboard register resources] at acpi0 not configured
PNP0000 [AT Interrupt Controller] at acpi0 not configured
PNP0200 [AT DMA Controller] at acpi0 not configured
PNP0100 [AT Timer] at acpi0 not configured
PNP0B00 [AT Real-Time Clock] at acpi0 not configured
PNP0800 [AT-style speaker sound] at acpi0 not configured
npx0 at acpi0 (PNP0C04)
npx0: io 0xf0-0xff irq 13
npx0: using exception 16
fdc0 at acpi0 (PNP0700)
dsmthdat-0574 [15] DsMethodDataGetValue  : Uninitialized Local[0] at node 0xc0bcad08
 dswexec-0526 [11] DsExecEndOp           : [Store]: Could not resolve operands, AE_AML_UNINITIALIZED_LOCAL
 psparse-1286: *** Error: Method execution failed [\_SB_.PCI0.FDC0._CRS] (Node 0xc0bd7e28), AE_AML_UNINITIALIZED_LOCAL
  uteval-0178: *** Error: Method execution failed [\_SB_.PCI0.FDC0._CRS] (Node 0xc0bd7e28), AE_AML_UNINITIALIZED_LOCAL
fdc0: ACPI: unable to get Current Resources: 12295
fdc0: unable to parse resources
com0 at acpi0 (PNP0501-1)
com0: io 0x3f8-0x3ff irq 4
com0: ns16550a, working fifo
com1 at acpi0 (PNP0501-2)
com1: io 0x2f8-0x2ff irq 3
com1: ns16550a, working fifo
lpt0 at acpi0 (PNP0401-1)
lpt0: io 0x378-0x37f,0x778-0x77b irq 7 drq 3
pci0 at mainbus0 bus 0: configuration mode 1
pci0: i/o space, memory space enabled, rd/line, rd/mult, wr/inv ok
pchb0 at pci0 dev 0 function 0
pchb0: VIA Technologies VT82C691 (Apollo Pro) Host-PCI (rev. 0xc4)
agp0 at pchb0: aperture at 0xd0000000, size 0x10000000
ppb0 at pci0 dev 1 function 0: VIA Technologies VT82C598 (Apollo MVP3) CPU-AGP Bridge (rev. 0x00)
pci1 at ppb0 bus 1
pci1: i/o space, memory space enabled
vga0 at pci1 dev 0 function 0: 3Dfx Interactive Banshee (rev. 0x03)
wsdisplay0 at vga0 kbdmux 1: console (80x25, vt100 emulation)
wsmux1: connecting to wsdisplay0
pcib0 at pci0 dev 7 function 0
pcib0: VIA Technologies VT82C596A (Apollo Pro) PCI-ISA Bridge (rev. 0x23)
pciide0 at pci0 dev 7 function 1: VIA Technologies VT82C596A (Apollo Pro) ATA66 controller
pciide0: bus-master DMA support present
pciide0: primary channel configured to compatibility mode
wd0 at pciide0 channel 0 drive 0: <QUANTUM FIREBALLlct10 15>
wd0: drive supports 16-sector PIO transfers, LBA addressing
wd0: 14324 MB, 16383 cyl, 16 head, 63 sec, 512 bytes/sect x 29336832 sectors
wd0: 32-bit data port
wd0: drive supports PIO mode 4, DMA mode 2, Ultra-DMA mode 4 (Ultra/66)
pciide0: primary channel interrupting at irq 14
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 4 (Ultra/66) (using DMA data transfers)
pciide0: secondary channel configured to compatibility mode
atapibus0 at pciide0 channel 1: 2 targets
cd0 at atapibus0 drive 0: <PCRW804, 4VO2026DG02855, 1.1> cdrom removable
cd0: 32-bit data port
cd0: drive supports PIO mode 4, DMA mode 2
pciide0: secondary channel interrupting at irq 15
cd0(pciide0:1:0): using PIO mode 4, DMA mode 2 (using DMA data transfers)
uhci0 at pci0 dev 7 function 2: VIA Technologies VT83C572 USB Controller (rev. 0x11)
uhci0: interrupting at apic 2 int 12 (irq 12)
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: VIA Technologies UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
pchb1 at pci0 dev 7 function 3
pchb1: VIA Technologies product 0x3050 (rev. 0x30)
ex0 at pci0 dev 17 function 0: 3Com 3c905-TX 10/100 Ethernet (rev. 0x0)
ex0: interrupting at apic 2 int 11 (irq 11)
ex0: MAC address 00:60:97:6e:ab:e6
exphy0 at ex0 phy 24: 3Com internal media interface
exphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
eap0 at pci0 dev 20 function 0: Ensoniq CT5880 CT5880-C (rev. 0x02)
eap0: interrupting at apic 2 int 10 (irq 10)
eap0: SigmaTel STAC9721/23 codec; 18 bit DAC, 18 bit ADC, SigmaTel 3D
audio0 at eap0: full duplex, mmap, independent
eap0: attaching secondary DAC
audio1 at eap0: full duplex, mmap, independent
midi0 at eap0: AudioPCI MIDI UART
isa0 at pcib0
pcppi0 at isa0 port 0x61
midi1 at pcppi0: PC speaker
spkr0 at pcppi0
sysbeep0 at pcppi0
isapnp0 at isa0 port 0x279: ISA Plug 'n Play device support
isapnp0: no ISA Plug 'n Play devices found
cpu0: prelint0 700<vector=0,delmode=7,dest=0> 0<target=0>
cpu0: prelint1 400<vector=0,delmode=4,dest=0> 0<target=0>
cpu0: timer0 300c0<vector=c0,delmode=0,masked,dest=0> 0<target=0>
cpu0: pcint0 10000<vector=0,delmode=0,masked,dest=0> 0<target=0>
cpu0: lint0 10700<vector=0,delmode=7,masked,dest=0> 0<target=0>
cpu0: lint1 400<vector=0,delmode=4,dest=0> 0<target=0>
cpu0: err0 10000<vector=0,delmode=0,masked,dest=0> 0<target=0>
ioapic0: enabling
ioapic0: int3 1d1<vector=d1,delmode=1,dest=0> 0<target=0>
ioapic0: int4 1d0<vector=d0,delmode=1,dest=0> 0<target=0>
ioapic0: int7 190<vector=90,delmode=1,dest=0> 0<target=0>
ioapic0: int10 a1b0<vector=b0,delmode=1,actlo,level,dest=0> 0<target=0>
ioapic0: int11 a170<vector=70,delmode=1,actlo,level,dest=0> 0<target=0>
ioapic0: int12 a162<vector=62,delmode=1,actlo,level,dest=0> 0<target=0>
ioapic0: int14 160<vector=60,delmode=1,dest=0> 0<target=0>
ioapic0: int15 161<vector=61,delmode=1,dest=0> 0<target=0>
uhub0: port error, restarting port 1
uhub0: port error, giving up port 1
uhub1 at uhub0 port 1
uhub1: Atmel Standard USB Hub, class 9/0, rev 1.10/3.00, addr 2
uhub1: 4 ports with 4 removable, self powered
uhidev0 at uhub1 port 1 configuration 1 interface 0
uhidev0: Logitech USB Mouse, rev 1.10/6.10, addr 3, iclass 3/1
ums0 at uhidev0: 3 buttons and Z dir.
wsmouse0 at ums0 mux 0
uscanner0 at uhub1 port 2
uscanner0: Canon CanoScan, rev 1.00/1.00, addr 4
uhidev1 at uhub1 port 4 configuration 1 interface 0
uhidev1: Logitech Logitech USB Keyboard, rev 1.10/12.10, addr 5, iclass 3/1
ukbd0 at uhidev1
wskbd0 at ukbd0 mux 1
wskbd0: connecting to wsdisplay0
uhidev2 at uhub1 port 4 configuration 1 interface 1
uhidev2: Logitech Logitech USB Keyboard, rev 1.10/12.10, addr 5, iclass 3/0
uhidev2: 3 report ids
uhid0 at uhidev2 reportid 1: input=2, output=1, feature=0
uhid1 at uhidev2 reportid 2: input=1, output=0, feature=0
ums1 at uhidev2 reportid 3: 0 buttons and Z dir.
wsmouse1 at ums1 mux 0
boot device: wd0
root on wd0a dumps on wd0b
root file system type: ffs
cpu1: prelint0 10000<vector=0,delmode=0,masked,dest=0> 0<target=0>
cpu1: prelint1 10000<vector=0,delmode=0,masked,dest=0> 0<target=0>
cpu1: timer0 200c0<vector=c0,delmode=0,dest=0> 0<target=0>
cpu1: pcint0 10000<vector=0,delmode=0,masked,dest=0> 0<target=0>
cpu1: lint0 10000<vector=0,delmode=0,masked,dest=0> 0<target=0>
cpu1: lint1 10000<vector=0,delmode=0,masked,dest=0> 0<target=0>
cpu1: err0 10000<vector=0,delmode=0,masked,dest=0> 0<target=0>
cpu1: CPU 1 running
wsdisplay0: screen 1 added (80x25, vt100 emulation)
wsdisplay0: screen 2 added (80x25, vt100 emulation)
wsdisplay0: screen 3 added (80x25, vt100 emulation)
wsdisplay0: screen 4 added (80x25, vt100 emulation)

--M9NhX3UHpAaciwkO--