Subject: NFS hangups
To: None <>
From: Julio Merino <>
List: current-users
Date: 12/22/2002 11:31:07

I'm running a NFS server on a NetBSD 1.6_STABLE machine. The exports file
contains a single line: /export/ftp -maproot=root

I mounted that directory on my machine, NetBSD 1.6K, like:
mount -t nfs sun:/export/ftp /ftp

And copied several files into it:
cd /ftp/pub/packages/darkstar
( cd /e/packages/darkstar ; tar cf - . ) | tar xf -

This went fine. All the packages plus symlinks were copied into the remote
NFS directory. But when I try to do "ls /ftp/pub/packages/darkstar/All" the
command gets stalled. And when I go to reboot (it is impossible to kill the
process), the kernel says "syncing... done" and then it stays there forever;
it can't reboot the machine. (I can enter DDB and say "reboot", which works
but then all fs are checked during bootup).

So, I rebooted and tried again. Same problem with the ls command in that
directory; although, if I try to list some of the category directories,
the command finishes properly. Reboot again, this time with OpenBSD 3.2.
I tried the mount there, and later the ls command; went perfectly, so I deduce there is some problem in NetBSD's current kernel.

I wonder if this can be caused by NEW_BUFQ_STRATEGY. I will rebuild a kernel
without it later and try again.

Any idea?


Julio M. Merino Vidal <>
The NetBSD Project -