Subject: NFS timeouts (sorta weird)
To: None <>
From: Peter Seebach <>
List: current-users
Date: 12/16/2002 21:19:03
So, I have a little netbooting box, and for a long time, it Just Worked.
A while back (maybe September?) I started having trouble with it.  Sometimes
it can netboot.  Sometimes it can't.  When it can't, the symptom is

mount_nfs: bad MNT RPC: RPC: Timed out

What's weird is, sometimes just trying again makes it work.

I've tried this with and without the TCP/IP flag on mounts; it doesn't seem
to matter.  Same exact hardware every time.

The kernel for this box defines

options         NFS_RSIZE=8192
options         NFS_WSIZE=8192

but this was only necessary (as I understand it) with UDP; it shouldn't
matter with TCP mounts, but they have the same problem.

Once a filesystem is mounted, it works beautifully, but mounting appears to
work about one time in three.  If a given filesystem doesn't mount on the
first try, no force on earth can make it mount later.

There must be *something* here I don't know about.