Subject: Can't log in after reboot
To: None <>
From: Oliver Schweitzer <>
List: current-users
Date: 12/08/2002 18:18:15

i am running current-hpcmips (ca. 5 days old) on an IBM workpad z50. Currently I can't logon after rebooting. 

Following largely,

1. I compiled a kernel. The kernel worked good.
2. updated /usr/src from cvs
3. Built the tool-chain ./  -t
4. Built/updated the system ./  
5. tried etcupdate (which didn't work out, but i ignored this (dumb?))

Then I rebooted.

After login as root, the shell starts run something, it goes until Terminal type is VT100, and then:

free: called with unallocated block argument
Stopping myself... terminates, restarts and back to the login prompt. When I login as a user, same as above, except

free: called with unallocated block argument
last command: su -
Stopping myself...

When I boot an old (1.6 generic) kernel:

Date/time init: /bin/sh on /etc/rc terminated abnormally, going to single user mode
Enter pathname of shell or RETURN for /bin/sh: <RETURN>
Date/time init: single user shell terminated, restarting

I only got the console, no remote login possible. everything else (net and such) starts up good afaik. I can mount the microdrive in my linux notebook if needed.

How can I fix my system?

Thanks in advance,