Subject: groff/-current build problems
To: None <>
From: Jeff <>
List: current-users
Date: 12/05/2002 21:41:16
I have a little more information on this now,
The time between between my last working -current userland build, and this
attempt was approx 13 days (so that makes it 15-16 days now, as of
Dec 5th)

I have tried, removing /usr/src entirely, and re-checking it out, no change.

I try /usr/bin/groff, and it works.  I try /usr/tools/bin/nbgroff, and 
that produces the same error below "cant find DESC file"...etc

I tried the env variable GROFF_FONT_PATH, no difference.

I copied /usr/bin/groff into /usr/tools/bin/nbgroff, to no avail, as well 
as coping /usr/bin/* to the corresponding /usr/tools/lib/groff/*.

That resulted in:
/usr/tools/bin/nbgroff: troff: Segmentation fault (core dumped)
/usr/tools/bin/nbgroff: grotty: Abort trap (core dumped)
at the same place during the build.

/usr/tools/share/groff/font/ has the devascii directory, as well as a DESC file
w/in said directory

/usr/share/groff_font/ has devascii as well, and a DESC file in that dir.

hopefully I am not alone in this, or someone knows what may be wrong...
below is my original message, with what leads up to the error.

Thank you

----- Forwarded message -----
Trying to build -current sources, I run into this:

building llib-lc.ln
Lint pass2:
sed -e 's/mdX/md2/g' -e 's/MDX/MD2/g' /usr/src/lib/libc/md/mdX.3 > md2.3
cat /usr/src/lib/libc/md/md2.copyright >> md2.3
sed -e 's/mdX/md4/g' -e 's/MDX/MD4/g' /usr/src/lib/libc/md/mdX.3 > md4.3
cat /usr/src/lib/libc/md/md4.copyright >> md4.3
sed -e 's/mdX/md5/g' -e 's/MDX/MD5/g' /usr/src/lib/libc/md/mdX.3 > md5.3
cat /usr/src/lib/libc/md/md5.copyright >> md5.3
PATH=/usr/tools/lib/groff:${PATH} /usr/tools/bin/nbgroff -Tascii -mtty-char -man
doc /usr/src/lib/libc/db/man/btree.3  > btree.cat3.tmp && mv btree.cat3.tmp btre
/usr/tools/bin/nbgroff: can't find `DESC' file
/usr/tools/bin/nbgroff:fatal error: invalid device `ascii'
Abort trap - core dumped
*** Error code 134

I have the most recent source off of, but I have seen
that sometimes lag behind a little.  Is this something that has been fixed/
seen by others/my fault I am overlooking?
----- End forwarded message -----