Subject: Re: Problems compiling cyrus-sasl v 2.1.9 (and .7, .8)
To: Yoseff Francus <>
From: Chris Gilbert <>
List: current-users
Date: 10/28/2002 08:13:40
On Sun, 27 Oct 2002 23:39:18 -0500 (EST)
Yoseff Francus <> wrote:

> Running NetBSD 1.5.3 on a pmax
> When I configure using shared libraries I keep getting warnings during
> compilation about
> inter-library dependencies not being supported.
> Unfortunately I am not told what library it thinks there is a
> dependency on.
> When compiled as just a static library it compiles fine but cannot get
> saslpasswd2 to create entries for DIGEST-MD5 or CRAM-MD5
> Has anyone seen these problems?

Is this using the newly created (yesterday) packages in pkgsrc? I saw
the same issue using just configure, and gmake, it turns out it needs
some libtool magic (to do with ltconfig) It certainly cured that problem
on i386 and arm, I suggest you try the pkgsrc version.