Subject: Re: aperture driver and 1.6I
To: None <>
From: Rick Kelly <>
List: current-users
Date: 10/10/2002 21:54:06
Rick Kelly said:

>Just upgraded my -current machine to 1.6I. The aperture driver no longer
>works. I'm running (or was running) XFree86 < 4.0. I tried rebuilding the
>aperture driver, but it doesn't compile anymore.

More info. Trying to build later aperture driver:

depend ===> module
mkdep -a   -nostdinc -I. -I/usr2/src/pkgsrc/sysutils/aperture/work/module -isystem /usr/src/sys -isystem /usr/src/sys/arch -D_KERNEL -D_LKM  aperture.c i686_mem.c k6_mem.c xf86_mod.c
xf86_mod.c:34: macro `MOD_DEV' used with only 4 args
mkdep: compile failed.
*** Error code 1

make: stopped in /usr2/src/pkgsrc/sysutils/aperture/work/module
*** Error code 1


Rick Kelly