Subject: Re: Broken 1.6?
To: VAX porting list <>
From: Johnny Billquist <>
List: current-users
Date: 10/08/2002 14:48:52
> Hmmm. Booting the 1.6 kernel seem to have helped. Now I'll have to figure
> out what have happened to the kernel to break things in non-obvious
> ways... Sorry about rambling about libc. That wasn't where the problem
> was, it was just a symptom of something else...

Turned out COMPAT_16 was needed. Without it, even with a "new" -current,
some programs don't work (such as csh and inetd).
Ragge was the one who knew what was going on, though. The syscall
framework have changed, and if COMPAT_16 isn't included, the old syscalls
all will give illegal instruction signals.

Sorry to have made such a fuzz over this.


Johnny Billquist                  || "I'm on a bus
                                  ||  on a psychedelic trip
email:           ||  Reading murder books
pdp is alive!                     ||  tryin' to stay hip" - B. Idol