Subject: Re: Promise Ultra133 TX2 backpatch
To: John <>
From: Manuel Bouyer <>
List: current-users
Date: 10/03/2002 21:57:12
On Thu, Oct 03, 2002 at 02:18:46AM -0500, John wrote:
> Just writing to get an opinion.
> I've got a pdc 20269 and am running 1.5.3 on an i386.
> I'm thinking about taking sys/dev/pci/pciide.c and making a patch from
> 1.153.25 (the netbsd-1-6-rc3 version) to (the netbsd 1.5.3
> version) so I can have the card supported on my system while still running
> an otherwise stable system.
> Any advice, warnings, etc?
> Is there a better approach to get my card working on a 1.5.3 kernel?
> (Run 1.6rc3 is what your thinking, isn't it!)

If you don't like the rc3, just run the 1.6 release :)

> Should I be aware of any other files that I must also update?
> Eg, I discovered pcidevs and its makefile.

You may also need to update pciide_pdc202xx_reg.h

Manuel Bouyer <>